[SOLVED] Stability Pool Staking issues

So I made a swap from ADA to iBTC, and have been trying to stake it into the stability pool for the last hour. Unfortunately I have continuously been receiving the error on the second stage of the transaction process (Balance). The error states “An error has occurred: CouldNotGetCollateral”. Is the network to congested?
As a side note, I have about 300 ADA still sitting in my lace wallet, I did this to attempt to troubleshoot the issue, assuming I needed more ADA in order to interact with the contract. But this doesn’t seem to be the case. Any help on this subject would be appreciated as I am still very new to the DeFi space.

1 Like

This error usually happens because you have not setup a collateral in your wallet.
If you are using eternl wallet, here’s where you need to go:
1- Go to “Settings” tab
2- Switch on the “collateral” toggle, as in the screenshot below

I never used lace wallet so I am not sure if the buttons are similar or not. This should fix your problem.


So I switched to Eternl and adjusted the collateral settings as I could not find this setting within lace, and voila! Problem solved! Thank you for your response!